Рапидшара, стеллариум и аниме

Сергей Голубицкий
Опубликовано 19 октября 2005 года

© 2006, Издательский дом «КОМПЬЮТЕРРА» | http://www.computerra.ru/
Журнал «Компьютерра» | http://www.computerra.ru/
Этот материал Вы всегда сможете найти по его постоянному адресу: http://offline.computerra.ru/offline/2005/610/234265/

Сегодняшнюю "Голубятню" посвящаю софтверному обеспечению, придающему пользовательский комфорт в условиях революционной реструктуризации информационно-развлекательных порталов, о которой я рассказывал читателям еще весной.

Напомню, о чем речь. В начале этого года сайты Avaxhome, Medigo, Капитан Немо и иже с ними дружно превратились из скучных бакунианских междусобойчиков в цветущую греческую агору, после того как установили специальный "блоггерский" движок, позволяющий всем желающим делиться любимой музыкой, электронными текстами, видео, компьютерными программами и тем, что Феликс Мучник благообразно окрестил "ой, надо же! - порнуха". Результатом реструктуризации необакунианцев стал феноменальный, фантастический, фантасмагорический рост посещаемости и популярности их порталов, в то время как официальные софтоотстойники впали в окончательную и безнадежную кому.

Сегодня, однако, нас интересует не столько пропагандистски-нравственный аспект случившейся информационной революции, сколько ее техническая подоплека. Даю рекогносцировку: львиная доля контента, распространяемого в современных необакунианских блоггах, - тексты, звуки, исполняемый код и видео, - хранится в файлохранилищах типа RapidShare, MegaUpload, QuickFile и Mytempdir. Причины лежат на поверхности. Неунывающие и вечно бдящие борцы за неприкосновенность авторских прав на информационные продукты постоянно отслеживают утечки контрафакта и глушат ftp-серверы на корню: не успел незадачливый "либертарианец" (тот самый "любитель халявы") выложить у себя какую-нибудь песенку Бритнёвой Спирсни, как его тут же жучат - стучат на хостинг и заодно с контрафактным контентом гонобобят весь сайт. Во избежание подобных эксцессов и было принято единодушное решение делегировать права хранения информации крупным файлохранилищам, которые бдящей публике прикрыть несоизмеримо труднее, а при грамотном юридическом сопровождении - так и совсем не по силам.

Так вот, теоретически файлохранилища эти бесплатны, однако на практике обставлены частоколом малоприятных ограничений типа обязательного лицезрения рекламных баннеров в течение заданного количества минут и/или лимитов на объем загрузки, сопровождаемых длительными таймаутами.

Самая высокая скорость загрузки - у Рапидшары, у нее же и самый большой таймаут: после каждых скачанных 20 Мбайт полагается ждать целый час. Согласитесь, некомильфо. Для обустройства общежития с Рапидшарой была создана софтина All in One RapidShare Pack 2.0 (рис. 1), сварганенная вьетнамским человеком по кличке Joketar. All in One автоматизирует целый ряд задач, связанных с Рапидшарой, как-то: поиск файлов, программ, фильмов и электронных книг на файлохранилище, быстрый доступ к прокси-рулеткам, включая встроенный модуль Hide Ip-Platinum, и - главное! - принудительная смена IP-адреса и удаление cookies, по которым RapidShare отслеживает вашу квоту загрузок и сроки таймаута. В принципе эти операции можно запросто проделать своими ручками - инструкций про обхождению таймаута RapidShare в Сети хоть отбавляй, - только муторно все это как-то. Гораздо удобнее доверить манипуляции вьетнамским программистам, былым нашим братьям по оружию (вопреки недоброй памяти жареной селедке!).

Аналогичная утилита для преодоления таймаута файлохранилища MegaUpload, вышедшая из-под пера индийского человека Деепеша Агарвала, называется MegaLeecher (рис. 2).

По гамбургскому счету MegaLeecher вызывает у меня скептицизм: таймаут на MegaUpload, как правило, не превышает одной минуты… Надо совсем обнаглеть от безнаказанности и халявы, чтобы создавать ("… и тем более пользоваться!" - углубил бы меру нравственного падения Феликс Мучник) программы для устранения столь пустякового ограничения. Впрочем, наше с Феликсом брюзжание все равно не остановит полет фантазии жителей бывших колониальных империй, мстящих сегодня былым поработителям.

Венцом борьбы вконец разленившихся "любителей халявы" с бесплатными файлохранилищами стала программа замечательного нашего соотечественника по прозвищу Dimonius (в миру Дмитрий) - Universal Share Downloader, которая предлагает несколько более цивилизованный подход к решению ситуации с ограничениями по скорости загрузки и таймаутами. Подход этот продиктован спецификой биографии программиста: за плечами Димониуса - музыкальная школа, институт и даже - страшно сказать! - аспирантура… Сами понимаете - с подобным багажом как-то не пристало грубо взламывать защиту файлохранилищ, поэтому в Universal Share Downloader реализован, если можно так выразиться, конфуцианский подход.

На что рассчитывает Рапидшара со товарищи, заставляя пользователей томиться 60 минут в ожидании очередной порции закачки? Правильно: на то, что рано или поздно пользователям либо наскучит ждать, либо они просто запутаются в своих многочисленных загрузках. И тогда, глядишь (чем черт не шутит!), махнут рукой да и подпишутся на платный сервис, в котором все ограничения сняты как по мановению волшебной палочки. Universal Share Downloader заставляет файлохранилища навеки распрощаться со своими иллюзиями: запускаем программу, забиваем в нее сразу все нужные нам ссылки и забываем обо всей головной боли до лучших времен. Программа самостоятельно и вовремя все скачает и разложит по полочкам. В настоящее время она поддерживает следующие файлохранилища: RapidShare.de, MyTempDir. com, qFile.de и WebFile.ru. Однако благодаря открытой архитектуре Universal Share Downloader можно легко добавлять поддержку других хостингов.

Особенно теплых слов заслуживает элегантно-спартанский интерфейс программы, выверенность настроек и такие маленькие, но приятные удобства, как слежение за буфером обмена: достаточно выделить какой-нибудь рапидшарный линк, как он сразу же попадает в Universal Share Downloader и автоматически обрабатывается.

А вот программа из совершенно иной оперы. Stellarium (рис. 3) - это приятное пополнение моей астрономической (не путать с астрологической!) копилки.

Читатели, знакомые с картами звездного неба, описанными в "Голубятнях", - от профессионального Redshift до фаворита Starry Night Enthusiast, - не найдут в Stellarium ничего нового с точки зрения функциональности и чисто научной информативности. Во всех отношениях бесплатный ("гуньевский") Stellarium уступает своим коммерческим конкурентам. Во всех - кроме одного: графики! Небесная сфера выписывается этой программой с красочностью и сочностью, совершенно недостижимыми для "взрослых" программ. Даже при отключенной опции, выполняющей наложение художественных репродукций на созвездия, реалистичность небосвода заставляет затаить дыхание любого неравнодушного человека. Ага, вот оно - точное определение: программа Stellarium создана не столько для тех, кто изучает науку астрономию, сколько для тех, кто влюблен в звезды!

Под занавес, с превеликим удовольствием представляю всем единомышленникам замечательный сетевой ресурс - Anime Forever. На этом пермском портале любителей японской мультипликации - форум, чат, фанфики и шикарнейшая подборка DVD-дисков (411 сериалов!), которые за символическую по московским меркам плату (80 рублей за диск) высылают почтой в любое место страны. При желании диски можно не покупать, а просто обмениваться ими (один к одному), поскольку коммерческий аспект проекта пыхтит где-то на третьестепенных ролях на фоне желания расширить коллекцию и максимально распропагандировать любимое искусство. Хотя в последнем - большой нужды нет: подозрительно сразу после выхода моей прошлогодней темы номера ("Аниме: на стыке цивилизаций") японская мультипликация на "Горбушке" стала плодиться аки порась. Сегодня на этом великом базаре контрафакта киосков, торгующих аниме, уже гораздо больше, чем киосков с порнографией.

Линки, помянутые в "Голубятне", вы найдете на домашней странице internettrading.net/guru.

Телефон редакции: (495) 232-2263
E-mail редакции: site@computerra.ru
По вопросам размещения рекламы обращаться к Елене Агапитовой по телефону +7 (495) 232-2263 или электронной почте reclama@computerra.ru